Not compatible with Version 6.0 of Eagle

To report bugs in the router software

Not compatible with Version 6.0 of Eagle

Postby Mawrob » Wed Dec 14, 2011 12:53 am

Hi,

Just wanted to let folk know who use FreeRouting that the brd_to_dsn ulp no longer works and throws the following error:

file path(119)
syntax error

and stops at:

real mm2u(real val)

The new "copy from" feature also blew up and threw a bunch of errors. I have an email into support and hopefully it is a mistake on my part and not a major bug.

Version 6.0 appears to have some great new features but the schematics, boards, and libraries do not appear compatible with 5.11. I made the mistake of upgrading without backing up my main library and have lost about a months worth of footprints.

Be aware!

Thanks
Mawrob
 
Posts: 2
Joined: Fri Jan 28, 2011 11:43 am

Re: Not compatible with Version 6.0 of Eagle

Postby Elco » Wed Dec 21, 2011 4:26 pm

I have fixed the brd_to_dsn.ulp, and it is posted on the CADsoft website.
There is one remaining problem: Objects like holes define a keepout ring with a certain thickness. In EAGLE the circle is defined as circle.radius and circle.width.
The brd_to_dsn ULP picks only the radius size up (sets the diameter to 2xradius), which can cause routing violations after running the script to load the result in Eagle. The same happens with via's, but this is rarely visible since they are so small.

I have tried to fix it, but the ULP is not well documented. The diameter of all circles in the keepout layers can be increased with their width, but this causes other violations. I would need to know if other objects (like wires) also draw circles in the keepout layers.
Alfons?

Regards, Robert
Elco
 
Posts: 38
Joined: Wed Dec 21, 2011 4:15 pm

Re: Not compatible with Version 6.0 of Eagle

Postby newhobby » Tue Jan 31, 2012 4:52 am

I downloaded your version of the ULP and although it generated the DSN dine just fine, I'm having issues of loading it.
It freezes on loading and gets stuck there.
Attached is the DSN file.
What should I do?

Thanks,
RI
Attachments
ORPExpansion.zip
(167.32 KiB) Downloaded 330 times
newhobby
 
Posts: 7
Joined: Tue Jan 31, 2012 4:47 am

Re: Not compatible with Version 6.0 of Eagle

Postby alfons » Tue Jan 31, 2012 8:23 am

newhobby wrote:I downloaded your version of the ULP and although it generated the DSN dine just fine, I'm having issues of loading it.
It freezes on loading and gets stuck there.
Attached is the DSN file.
What should I do?

Thanks,
RI


There is a problem with the board outline.
The ulp-file has generated an almost endless number of boundary scopes in the .dsn-file.
If I delete all boundary scopes beside the first in your attached .dsn-file, the file loads without any problem.
Perhaps you should try to create a simpler board outline in Eagle to begin with.
alfons
Site Admin
 
Posts: 188
Joined: Sun Nov 30, 2008 10:30 am
Location: Munich, Germany

Re: Not compatible with Version 6.0 of Eagle

Postby newhobby » Tue Jan 31, 2012 3:35 pm

Weird.
It's the same type of board outline I have used in the past on version 5.6.
Is an updated ULP going to be released?
newhobby
 
Posts: 7
Joined: Tue Jan 31, 2012 4:47 am


Return to Bug Report

Who is online

Users browsing this forum: No registered users and 2 guests