Infinite "Loading design..."

To report bugs in the router software

Infinite "Loading design..."

Postby Manveru » Wed Jul 06, 2011 10:16 pm

I have PCB exported to DSN from KiCad, when I am trying to open it in FreeRouting, the application hangs on "Loading design...". The problematic file attached.

Why FreeRouting cannot report problems with the design file as error message?

How big donation may incline you to add better error handling at the design load stage? Maybe the community can "buy" some portions of the source code to add such extensions in parser which would allow users to not annoy you with their problems according not faultless DSN files?

Thank you in advance for your answer.
Attachments
motor_drivers_ii.dsn.gz
My DSN file from KiCAD
(6.56 KiB) Downloaded 355 times
Manveru
 
Posts: 4
Joined: Wed Jul 06, 2011 10:02 pm

Re: Infinite "Loading design..."

Postby alfons » Fri Jul 08, 2011 8:15 am

The problem is created once more by the superfluous PN-scopes.

See my answers to the message at http://www.freerouting.net/fen/viewtopic.php?f=5&t=111.
alfons
Site Admin
 
Posts: 188
Joined: Sun Nov 30, 2008 10:30 am
Location: Munich, Germany

Re: Infinite "Loading design..."

Postby Manveru » Sun Jul 10, 2011 3:51 pm

There is a project QAutoRouter which is at early stage, however it at least reads my DSN files correctly without dawdle.
Manveru
 
Posts: 4
Joined: Wed Jul 06, 2011 10:02 pm

Re: Infinite "Loading design..."

Postby usul » Wed Jul 13, 2011 12:12 pm

I'm having the same problem. I removed all PN scopes from the DSN-File (original: vol1.dsn, edited: x.dsn), but Freerouter still hangs on import. What else could be the problem?
Attachments
examples.zip
(8.38 KiB) Downloaded 357 times
usul
 
Posts: 2
Joined: Wed Jul 13, 2011 12:00 pm

Re: Infinite "Loading design..."

Postby alfons » Thu Jul 14, 2011 8:20 am

usul wrote:I'm having the same problem. I removed all PN scopes from the DSN-File (original: vol1.dsn, edited: x.dsn), but Freerouter still hangs on import. What else could be the problem?


In my environment (Windows 7) Freerouter imports the two attached design files without any problem.
alfons
Site Admin
 
Posts: 188
Joined: Sun Nov 30, 2008 10:30 am
Location: Munich, Germany

Re: Infinite "Loading design..."

Postby usul » Thu Jul 14, 2011 11:22 am

Interesting, tried it on MacOS 10.6 and Linux, on both platforms it got stuck. I will do tests with other platforms.
usul
 
Posts: 2
Joined: Wed Jul 13, 2011 12:00 pm


Return to Bug Report

Who is online

Users browsing this forum: No registered users and 1 guest

cron